Plugin Service

Something is missing? Have an idea? Ask for new stuff here.
Post Reply
User avatar
F43nd1r
Posts: 33
Joined: Thu Jan 24, 2019 1:20 pm

Plugin Service

Post by F43nd1r » Tue Feb 05, 2019 6:57 pm

I was working on my first addition to LL, a service which would make plugins easier to create.
I imagine it to be similar to what the repository importer provides, but integrated into lightning. Which makes it more powerful, stable, and easier to implement.

@Pierrot now, my problem is, how do I upload this to the git repository, so you can have a look at it? I tried to push to a new branch, but i got "remote rejected" back.

User avatar
Pierrot
Site Admin
Posts: 181
Joined: Wed Jan 23, 2019 12:18 pm
Location: French Alps

Re: Plugin Service

Post by Pierrot » Wed Feb 06, 2019 6:30 am

I don't know what's wrong. I tried to push a test branch using your login and it worked. I was also able to delete it. Do you have a longer error message?

User avatar
F43nd1r
Posts: 33
Joined: Thu Jan 24, 2019 1:20 pm

Re: Plugin Service

Post by F43nd1r » Thu Feb 07, 2019 5:15 am

Code: Select all

LANG=EN git push --set-upstream origin pluginService
Enumerating objects: 45, done.
Counting objects: 100% (45/45), done.
Delta compression using up to 16 threads
Compressing objects: 100% (19/19), done.
Writing objects: 100% (29/29), 3.98 KiB | 1.99 MiB/s, done.
Total 29 (delta 8), reused 0 (delta 0)
remote: error: insufficient permission for adding an object to repository database objects
remote: fatal: failed to write object
error: remote unpack failed: unpack-objects abnormal exit
To git.lightninglauncher.com:/home/git/apps/lightning_launcher.git
 ! [remote rejected] pluginService -> pluginService (unpacker error)
error: failed to push some refs to 'lukas@git.lightninglauncher.com:/home/git/apps/lightning_launcher.git'

User avatar
Pierrot
Site Admin
Posts: 181
Joined: Wed Jan 23, 2019 12:18 pm
Location: French Alps

Re: Plugin Service

Post by Pierrot » Thu Feb 07, 2019 9:02 am

ACLs were not correctly set on all files, thus resulting in the permission denial you got. I think it's fixed now. Sorry for the trouble.

User avatar
F43nd1r
Posts: 33
Joined: Thu Jan 24, 2019 1:20 pm

Re: Plugin Service

Post by F43nd1r » Thu Feb 07, 2019 6:06 pm

Yes, push worked now. Are you still thinking about setting up gitlab or something similar? I would like to create pull requests and discuss their purpose in one place, instead of doing it here.

User avatar
Pierrot
Site Admin
Posts: 181
Joined: Wed Jan 23, 2019 12:18 pm
Location: French Alps

Re: Plugin Service

Post by Pierrot » Fri Feb 08, 2019 3:19 pm

Done! (I just sent you an email)

Post Reply