Work in progress

Add new features to the community through phpBB plugins
Post Reply
User avatar
Pierrot
Site Admin
Posts: 181
Joined: Wed Jan 23, 2019 12:18 pm
Location: French Alps

Work in progress

Post by Pierrot » Fri Jan 25, 2019 7:41 am

As per suggestion from F43nd1r:

User avatar
Pierrot
Site Admin
Posts: 181
Joined: Wed Jan 23, 2019 12:18 pm
Location: French Alps

Re: Work in progress

Post by Pierrot » Fri Jan 25, 2019 8:54 am

I can't have the mention system to work. Extension is installed and as far as I can see the permission is set but it doesn't seem to be enough

User avatar
F43nd1r
Posts: 37
Joined: Thu Jan 24, 2019 1:20 pm

Re: Work in progress

Post by F43nd1r » Fri Jan 25, 2019 2:20 pm

@Pierrot it seems to me that the mention itself works, just not the notification. Maybe a problem with the php version?

User avatar
Pierrot
Site Admin
Posts: 181
Joined: Wed Jan 23, 2019 12:18 pm
Location: French Alps

Re: Work in progress

Post by Pierrot » Fri Jan 25, 2019 3:07 pm

I received the notification, but I'm still unable to use the mention. That's probably something related to permissions if it works for you. Damn!

User avatar
TrianguloY
Posts: 92
Joined: Thu Jan 24, 2019 9:46 am

Re: Work in progress

Post by TrianguloY » Fri Jan 25, 2019 6:38 pm

I'm able to autocomplete @Pierrot, and also @TrianguloY but not @F43nd1r. (maybe because the second character in your name is a number?)
Funny thing, after writing the '@' without a valid mention it can no longer be autocompleted (after that char, it can before the char). Probably a bug in the extension.

Let me try by writing the name manually:
@F43nd1r

And also let me try with an invalid username:
@InvalidUserName

User avatar
Pierrot
Site Admin
Posts: 181
Joined: Wed Jan 23, 2019 12:18 pm
Location: French Alps

Re: Work in progress

Post by Pierrot » Sat Jan 26, 2019 4:09 pm

Problem fixed :-) @F43nd1r
Indeed, the mention plugin used a regexp which wasn't including digits. I patched it and it works, you may have to do a full reload of the page to clear the browser cache.

User avatar
F43nd1r
Posts: 37
Joined: Thu Jan 24, 2019 1:20 pm

Re: Work in progress

Post by F43nd1r » Sun Jan 27, 2019 3:55 pm

Good. Email notifications work as well.

User avatar
Pierrot
Site Admin
Posts: 181
Joined: Wed Jan 23, 2019 12:18 pm
Location: French Alps

Re: Work in progress

Post by Pierrot » Mon Jan 28, 2019 8:29 am

Just installed https://github.com/lavigor/notifications, let's see whether it works on mobile devices: @Pierrot

User avatar
Pierrot
Site Admin
Posts: 181
Joined: Wed Jan 23, 2019 12:18 pm
Location: French Alps

Re: Work in progress

Post by Pierrot » Mon Jan 28, 2019 8:33 am

Not yet, a dependency was missing, trying again @Pierrot

User avatar
Pierrot
Site Admin
Posts: 181
Joined: Wed Jan 23, 2019 12:18 pm
Location: French Alps

Re: Work in progress

Post by Pierrot » Mon Jan 28, 2019 8:41 am

Ok, it works on mobile too: :-)

Post Reply